Author Topic: hell-0 long time no hub A?  (Read 4052 times)

retro_killa

  • 128-bit
  • ****
  • Posts: 1314
  • You must be the change you want 2 see in the world
    • Colorblind Designs
hell-0 long time no hub A?
« on: August 01, 2007, 04:31:20 AM »
it took me a while to find this site after they did the server change for the freaking 3 or 100th time lol...

anyways what the fuck is going on segahub ?

willplayer

  • 128-bit
  • ****
  • Posts: 1839
Re: hell-0 long time no hub A?
« Reply #1 on: August 01, 2007, 05:00:48 AM »
everything! :D

Jemsic

  • Guest
Re: hell-0 long time no hub A?
« Reply #2 on: August 01, 2007, 05:34:53 AM »
This is where it's at!  :D

retro_killa

  • 128-bit
  • ****
  • Posts: 1314
  • You must be the change you want 2 see in the world
    • Colorblind Designs
Re: hell-0 long time no hub A?
« Reply #3 on: August 01, 2007, 06:18:37 AM »
This is where it's at!  :D

thats right its all about the killa in you :)

darkNiGHTS

  • soccerboi
  • Administrator
  • 128-bit
  • *****
  • Posts: 4675
  • Is it getting dark in here, or is it just me?
Re: hell-0 long time no hub A?
« Reply #4 on: August 01, 2007, 06:43:14 AM »
Yay, retro's back!  We're just going through some change right now, and I happened to have to go away for 3 weeks right when that change was starting, so we're kinda stuck right now.

chandler_455

  • 128-bit
  • ****
  • Posts: 607
Re: hell-0 long time no hub A?
« Reply #5 on: August 01, 2007, 05:21:50 PM »
I never thought you'd come back retro


19/246 Dreamcast games and counting

NuTTy

  • 8-Bit
  • Posts: 47
Re: hell-0 long time no hub A?
« Reply #6 on: August 08, 2007, 07:12:48 PM »
welcome back  ;D

willplayer

  • 128-bit
  • ****
  • Posts: 1839
Re: hell-0 long time no hub A?
« Reply #7 on: August 08, 2007, 11:40:54 PM »
retro I miss your awesome article posts about random shit, bring them back!

xsonicx

  • 128-bit
  • ****
  • Posts: 1096
  • XBL: XsonicX08
Re: hell-0 long time no hub A?
« Reply #8 on: August 08, 2007, 11:44:02 PM »
Hey

RagePrblm

  • 8-Bit
  • Posts: 4
Re: hell-0 long time no hub A?
« Reply #9 on: March 04, 2009, 06:46:24 AM »
long time no see retro

willplayer

  • 128-bit
  • ****
  • Posts: 1839
Re: hell-0 long time no hub A?
« Reply #10 on: March 05, 2009, 12:00:11 AM »
woooow ... :D